Ubuntu12.04 64bit Rails

あれ。。Railsバージョンは。。忘れた。。
あとで調べますん


インストール後Tutorialやろうとしたらエラー連発したので。。


・$ rails new [appname]

言われたとおり

$ sudo gem install sqlite3 -v '1.3.1'

しても

checking for sqlite3.h... no が含まれるエラー出る

$ sudo apt-get install libsqlite3-dev

であらためて

$ sudo gem install sqlite3 -v '1.3.1' 

でおk

 

・$ rails server

Could not find a JavaScript runtime. See https://github.com/sstephenson/execjs for a list of available runtimes. (ExecJS::RuntimeUnavailable)

やらなんやらのエラー

$ sudo apt-get install python-software-properties $ sudo add-apt-repository ppa:chris-lea/node.js $ sudo apt-get update $ sudo apt-get install nodejs

でおk

 

・$ rake db:migrate

<span>undefined methodreference' for #<:connectionadapters::tabledefinition:></:connectionadapters::tabledefinition:>`

<span>db/migrate/~~~_create_comments.rb の</span>

t.reference →t.references

でおk

Tutorial

http://guides.rubyonrails.org/getting_started.html