Brew update failed

Phenomenon

$ brew update
Warning: git-2.9.1 already installed  
Error: Git must be installed and in your PATH!  

Cause

  • Outdated homebrew (Unsure...)

Solution

  • Update homebrew
$ cd /usr/local/Library/Homebrew
$ git pull origin master